しゃある通信

#05-01 古いOSにもインストール可能なrpmを作るには

 error: Failed dependencies:
 rpmlib(FileDigests) <= 4.6.0-1 is needed by ...
 rpmlib(PayloadIsXz) <= 5.2-1 is needed by ...
と出てrpmパッケージをインストールできない、古いOSの面倒を見なければならないお仕事、おつかれさまです。

rpmbuildのオプションに

--define="_binary_filedigest_algorithm 1" --define="_binary_payload w9.gzdio"
をつけてシグネチャをSHA256から古いMD5に、LZMA圧縮から古い形式のgzip圧縮に戻せばインストール可能なrpmを作成することができます。 古いOSを入れたビルド環境は必要ありません。たぶん。

gzip圧縮ではなくbzip2圧縮も可能っぽいけど、互換のためにgzipにしておいたほうがいい気がします。



マクロミルへ登録

© 2014 Kazuya 'Sharl' Masuda
(C)Willoo Entertainment Inc. (C)Konami Digital Entertainment 株式会社ウィローエンターテイメント及び株式会社コナミデジタルエンタテインメントの著作権を侵害する行為は禁止されています。 0.021249 cached